Support for Bedrock 1.19
Incident Report for SkyBlade
Resolved
We have monitored our 1.19 support and haven't discovered any significant issues. If you find anything abnormal, please report it to us as soon as possible.
Posted Jun 12, 2022 - 07:15 BST
Monitoring
Support for Bedrock Version 1.19 (and Switch version 1.19.1) has rolled out. We're actively monitoring the results of our developments and we urge that you report anything abnormal.
Posted Jun 07, 2022 - 19:35 BST
Identified
Support for Minecraft Bedrock 1.19 will be coming shortly. At this time, avoid updating if you wish to keep playing on SkyBlade. If you want to wait for SkyBlade to update first, check you don't have automatic updates enabled. We appreciate your patience as we work on supporting this version.
Posted Jun 07, 2022 - 15:50 BST