Performance and Stabilisation
Incident Report for SkyBlade
Resolved
These features are now re-enabled across the Network.
Posted Jun 29, 2021 - 19:45 BST
Investigating
We're constantly pushing changes to fix performance and stabilisation issues. Over the next few days, we're investigating some key issues across our Network. In order to do this, we are temporarily disabling certain features. You'll be updated here when we do and what we will temporarily disable.

At this time, the following are disabled:
- Player Profile
- Cosmetics
- Game Unlocks
- Global game statistic logging
- Opening Crates and Daily Rewards
- Collecting Network coins, crates and experience
- Reading current Network coins and experience in-game
Posted Jun 29, 2021 - 14:30 BST
This incident affected: SkyBlade.