External Server Connections
Incident Report for SkyBlade
Resolved
This issue has now been resolved and players should be able to connect to external servers as usual.
Posted Aug 23, 2021 - 21:45 BST
Identified
The issue regarding external server connections has been identified and our providers are working to get this resolved as soon as possible.
Posted Aug 23, 2021 - 20:40 BST
Investigating
We've been made aware that some players have been unable to connect to certain servers. We're actively investigating and currently have no estimated time frame as to when this will be resolved. We apologise for the disruption and we appreciate your patience in the meantime.
Posted Aug 22, 2021 - 12:20 BST