Support for Bedrock 1.17
Incident Report for SkyBlade
Resolved
We have monitored our initial 1.17 support and haven't discovered any significant issues. If you find anything abnormal, please report it to us as soon as possible.
Posted Jun 12, 2021 - 12:00 BST
Monitoring
Support for Bedrock Version 1.17 has rolled out. While we continue working on complete background support for this update, you'll be able to connect using the newest protocol. We're actively monitoring the results of our developments and we urge that you report anything abnormal.
Posted Jun 10, 2021 - 01:00 BST
Identified
Our support for Minecraft Bedrock 1.17 will be coming shortly. With this being a large update, we expect that this could take up to a week. At this time, avoid updating if you wish to keep playing on SkyBlade. We appreciate your patience with this - we're working as fast as we can.
Posted Jun 08, 2021 - 14:00 BST