Connections
Incident Report for SkyBlade
Resolved
This incident has been resolved.
Posted Jul 02, 2021 - 13:30 BST
Monitoring
We're continuing to monitor connection-based issues across the Network.
Posted Jun 30, 2021 - 16:00 BST
Investigating
We're currently investigating some back-end system issues. At this time, some users may not be able to connect to the Network. We apologise for the disruption.
Posted Jun 30, 2021 - 13:30 BST
This incident affected: SkyBlade.