Support for Bedrock 1.17.10
Incident Report for SkyBlade
Resolved
We have monitored our 1.17.10 support and haven't discovered any significant issues. If you find anything abnormal, please report it to us as soon as possible.
Posted Jul 16, 2021 - 17:00 BST
Monitoring
Support for Bedrock Version 1.17.10 has rolled out. While we continue working on complete background support for this update, you'll be able to connect using the newest protocol. We're actively monitoring the results of our developments and we urge that you report anything abnormal.
Posted Jul 13, 2021 - 22:30 BST
Identified
Support for Minecraft Bedrock 1.17.10 will be coming shortly. At this time, avoid updating if you wish to keep playing on SkyBlade. We appreciate your patience with this - we're working as fast as we can.
Posted Jul 13, 2021 - 21:00 BST